Go Back   Rangefinderforum.com > Cameras / Gear / Photography > Classic Film RangeFinders & Other Classics > Olympus RF

Olympus RF This forum is for the Olympus rangefinders.

Reply
 
Thread Tools Search this Thread Display Modes

HELP- Olympus XA3 film door wonít lock with film inside
Old 04-21-2019   #1
Andrew.Atmadja
Registered User
 
Andrew.Atmadja is offline
Join Date: Mar 2019
Location: Jakarta
Posts: 5
HELP- Olympus XA3 film door wonít lock with film inside

Hi all
Iím very much new here and this is my first post actually.
Recently I just bought few camera from my holiday to Japan and one of them was Olympus XA3 (mint condition).
I didnít get a chance to try the XA3 immediately so when I am back to my country I found out that the film door wonít close if there is a film cannister inside.

Without the film is fine but when I put the film inside it just wonít close.
I couldnít find what is wrong with the camera and I did try to google the problem but find nothing.

Does anyone ever had the same problem?
  Reply With Quote

Old 04-21-2019   #2
wwfloyd
Registered User
 
wwfloyd's Avatar
 
wwfloyd is offline
Join Date: Jan 2019
Posts: 137
Are you SURE you're closing the film door completely? One of my XA's has sort of a 2-stage feel to the latch. I fogged the beginning of a roll of film because I thought the door was latched, but, it popped open. It does latch properly when I deliberately close the door firmly.
  Reply With Quote

Old 04-21-2019   #3
ACullen
Registered User
 
ACullen is offline
Join Date: Jul 2016
Posts: 163
Are you certain that you have inserted the film correctly?
  Reply With Quote

Old 04-21-2019   #4
David Hughes
David Hughes
 
David Hughes's Avatar
 
David Hughes is offline
Join Date: Dec 2007
Posts: 7,507
Is the film pulled tight so the cassette is flat? usually slackness makes the cassette turn slightly and block doors; with most film cameras, btw...


Regards, David
  Reply With Quote

Old 04-21-2019   #5
Andrew.Atmadja
Registered User
 
Andrew.Atmadja is offline
Join Date: Mar 2019
Location: Jakarta
Posts: 5
Quote:
Originally Posted by wwfloyd View Post
Are you SURE you're closing the film door completely? One of my XA's has sort of a 2-stage feel to the latch. I fogged the beginning of a roll of film because I thought the door was latched, but, it popped open. It does latch properly when I deliberately close the door firmly.
I tried to close it but it keeps pushing back. I mean really really firm but it won't locked.
  Reply With Quote

Old 04-21-2019   #6
Andrew.Atmadja
Registered User
 
Andrew.Atmadja is offline
Join Date: Mar 2019
Location: Jakarta
Posts: 5
Quote:
Originally Posted by ACullen View Post
Are you certain that you have inserted the film correctly?
Yes, 100% sure and i tried the same film on my other cameras
  Reply With Quote

Old 04-21-2019   #7
Andrew.Atmadja
Registered User
 
Andrew.Atmadja is offline
Join Date: Mar 2019
Location: Jakarta
Posts: 5
Quote:
Originally Posted by ACullen View Post
Are you certain that you have inserted the film correctly?
Yes, 100% sure and i tried the same film on my other cameras.
I bring it to the repair shop and the guy hasn't found anything's wrong with the camera either
  Reply With Quote

Old 04-21-2019   #8
Andrew.Atmadja
Registered User
 
Andrew.Atmadja is offline
Join Date: Mar 2019
Location: Jakarta
Posts: 5
Quote:
Originally Posted by David Hughes View Post
Is the film pulled tight so the cassette is flat? usually slackness makes the cassette turn slightly and block doors; with most film cameras, btw...


Regards, David
hi David, I keep the film firmly in the chamber as I always do when I load any film in my camera (except on my M's).
This is the first time for me also to encounter such issue. I'm confused...

I was thinking it could be the position of the "hook" inside the film chamber because without the film everything is normal and easy.
Once I put the film inside the chamber it won't closed
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 22:37.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.