Need KM 5400 II Scanner repair
Old 01-05-2012   #1
srtiwari
Daktari
 
srtiwari's Avatar
 
srtiwari is offline
Join Date: Oct 2005
Location: Vero Beach, Florida
Posts: 1,018
Need KM 5400 II Scanner repair

My scanner suddenly refused to turn on, after being used just a few minutes earlier. my simple attempts to readjust the power cable etc., did nothing. Opening the case shows nothing "out of place" to my untrained eye. The scanner had not been moved/jostled etc., and I was just testing it to send off to someone interested in it.

I cannot get past Sony's automated answer system to talk to anyone, but understand they no longer fix scanners.
Precision camera (despite a "quote" for repair online), tell me they no longer have parts to fix KM scanners.

Anyone have any ideas about where I could look next ? Don't know if the regular camera repair guys (DAG etc) do this work. The KM 5400 II is a lovely scanner, and I'd hate to lose using it.
__________________
Subhash
  Reply With Quote

Old 01-05-2012   #2
Photon42
burn the box
 
Photon42's Avatar
 
Photon42 is online now
Join Date: Sep 2007
Location: Neutral Zone
Posts: 617
Quote:
Originally Posted by srtiwari View Post
My scanner suddenly refused to turn on, after being used just a few minutes earlier. my simple attempts to readjust the power cable etc., did nothing. Opening the case shows nothing "out of place" to my untrained eye. The scanner had not been moved/jostled etc., and I was just testing it to send off to someone interested in it.

I cannot get past Sony's automated answer system to talk to anyone, but understand they no longer fix scanners.
Precision camera (despite a "quote" for repair online), tell me they no longer have parts to fix KM scanners.

Anyone have any ideas about where I could look next ? Don't know if the regular camera repair guys (DAG etc) do this work. The KM 5400 II is a lovely scanner, and I'd hate to lose using it.
That may not help you, but my Coolscan V just went dead from one day to the other. After a couple of month, I decided to check it myself and opened it. So I found they actually did not provide the proper fuse (2A required but 1A slotted in), which eventually smoked the underspecified fuse.

After replacing it, the scanner works now for more than a year with no complaints.

Good luck

Ivo
__________________
My Gallery
My Instagram
  Reply With Quote

Old 01-05-2012   #3
srtiwari
Daktari
 
srtiwari's Avatar
 
srtiwari is offline
Join Date: Oct 2005
Location: Vero Beach, Florida
Posts: 1,018
Quote:
Originally Posted by Photon42 View Post
That may not help you, but my Coolscan V just went dead from one day to the other. After a couple of month, I decided to check it myself and opened it. So I found they actually did not provide the proper fuse (2A required but 1A slotted in), which eventually smoked the underspecified fuse.

After replacing it, the scanner works now for more than a year with no complaints.

Good luck

Ivo
Thank you, Ivo , for the response. I did open it, but could not figure out if/where there was a fuse. If I knew that I could give it a shot.
Subhash
__________________
Subhash
  Reply With Quote

Old 01-05-2012   #4
Photon42
burn the box
 
Photon42's Avatar
 
Photon42 is online now
Join Date: Sep 2007
Location: Neutral Zone
Posts: 617
For some reason I cannot upload images (quote problem, but I only have 134k used and the one I want to upload has 54k ...). Here is a link to the L-Forum for the picture of the Coolscan fuse. Maybe that helps.
__________________
My Gallery
My Instagram
  Reply With Quote

Old 01-05-2012   #5
cabbiinc
Slightly Irregular
 
cabbiinc is offline
Join Date: Dec 2011
Location: Western Washington
Posts: 235
I would ask the folks at KEH.com where they would suggest to send it for repairs. I don't have any experience with asking that question but I'd think if anyone knew where to send a scanner it would be them.
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 13:19.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.