Plustek 7200 Windows 10 all over again...
Old 09-10-2019   #1
olliewtf
Registered User
 
olliewtf is offline
Join Date: Sep 2018
Posts: 53
Plustek 7200 Windows 10 all over again...

Recently acquired a plustek 7200, confident I was clever enough to get it to work with vuescan on windows 10.

I found a great blog post outlining all sorts of trickery. Downloaded the old driver from plustek, ran it in compatibility mode with the signature thingy (the thing where it stops listening to what OS is running) so it would install, did the same with the demo version of Silverfast, and got the scanner to do its first scan in silverfast without a hitch (edit: after hours of working the above out!)

So todays mission was to get it to work with vuescan. I had failed in this endeavour, so proceeded to download the 32 bit version (demo) as I heard this was necessary to work with old drivers.

No luck.

I booted silverfast again to confirm all was well, and now that wont recognise the scanner either. Windows doesnt recoginse the scanner anymore, but i can see that the plustek driver is installed still. No idea what's happened overnight but Im out of options, other than a reboot, and trying the above all over again.

To confirm, I am booting each program with the scanner plugged in and switched on.

The reason for silverfast was as follows: I had read that not only is there all the complications around compatibility and signature bollocks, but vuescan will only pick up the scanner if it has been recognised by silverfast first.

Dont ask me to test any of that logic as im a little in over my head.

Any solutions very gratefully received!


thanks!
  Reply With Quote

Old 09-10-2019   #2
mpaniagua
Registered User
 
mpaniagua's Avatar
 
mpaniagua is offline
Join Date: Nov 2011
Location: Tijuana, Baja California, Mexico
Age: 46
Posts: 1,099
umm probably Vuescan relies on some configuration file from Silverfast? I use a Plustek 8100i with Silverfast for my 35mm negatives and once use it with Vuescan but go back to Silverfast since somehow I preferred the results I get on Silverfast.

Probably try to remove everything (Plustek drivers, Vuescan and Silverfast). Once Silvesfast wasn't recognizing the scanner so removed drivers and Silverfast. Installed again and then it started working again.


Try removing the scanner drivers using Device Manager.


Marcelo
  Reply With Quote

Old 09-11-2019   #3
olliewtf
Registered User
 
olliewtf is offline
Join Date: Sep 2018
Posts: 53
Thanks Marcelo

Im curious as to whether silverfast is necessary to get vuescan to recognise the scanner. Ive read as much; just not sure if i need to delete silverfast before booting vuescan?

Either way Ill try the whole thing over again; my feeling is that if i can repeat the process and get it to boot in silverfast, I then need to boot vuescan and if that works it hopefully will be fine. But Im just guessing here!

any more thoughts welcomed!
  Reply With Quote

Old 09-23-2019   #4
Nickon51
Registered User
 
Nickon51 is offline
Join Date: May 2008
Posts: 43
Does Vuescan's inbuilt driver not work in Windows 10. It covers pretty much any scanner.
  Reply With Quote

Old 09-23-2019   #5
olliewtf
Registered User
 
olliewtf is offline
Join Date: Sep 2018
Posts: 53
Solved!

Vuescan as far as Ive worked out doesn't have an in-built driver; their website blurb is pretty misleading in that respect. What I think it does mean is that new versions of vuescan will work with older scanners (whereas something like the new silverfast won't) but you still ahve to get windows 10 to recognise the scanner first.

So here's my solution for anyone stuck with the same problem.

Download the correct driver from plustek.

restart your computer in the mode that allows driver signature enforcement to be turned off. Run the installer for the driver in compatibility mode (XP) and install.

Go ahead and install silverfast in compatibility mode too.

Now silverfast might at this point work and find the scanner, it did for me. But the reason it didn't after that was the conundrum.

Now im not sure which part of the next bit made it work, but here it is in all its amateur glory.

I deleted it all and started over, including all the temp files. I also went into my device manager and clicked uninstall for the usb device (the scanner) that windows wasnt registering as the plustek.

After re installing everything with the scanner not plugged in, I then had to manually tell windows which driver to use. GO into the device manager and right click the usb device and go for update driver. Then go for the manual option. find the folder - and now this is the bit that i couldnt get my head around - tell it to use the folder with the installer package in, not the folder in your system files.

Hey presto, all working!


Now Im wondering if i can buy vuescan second hand of anyone as im loathed to fork out another 70 quid. Maybe i shouldve just stuck with the canoscan!

Good luck to anyone who tries this, but bottom line - it is possible to use a plustek 7200 on windows 10.
  Reply With Quote

Old 09-23-2019   #6
Nickon51
Registered User
 
Nickon51 is offline
Join Date: May 2008
Posts: 43
When you install or upgrade Viewscan you are asked if you want to install Vuescan's driver software. I used to worry about chasing around for the manufactures drivers, but it's not necessary. There are a lot of scanners out there where the manufacture has ceased support. Viewscan supports these very nicely. The Plustek scanners are in Hamrick's driver.


Silverfast can be a problem, you can only license 1 scanner at a time. That makes it difficult to use more than scanner. eg. I have a Coolscan and an Epson V800. Silverfast is a pita to switch between them.
  Reply With Quote

Old 09-24-2019   #7
olliewtf
Registered User
 
olliewtf is offline
Join Date: Sep 2018
Posts: 53
Interesting, I got no such notification - Id be surprised that so many have issues with windows 10 and the older plustek scanners if vuescan included the drivers?

Maybe I missed a super easy fix then! oh well. it wouldnt surprise me!
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 05:50.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.