Flash firing without advance next frame
Old 1 Week Ago   #1
yaacovk
Registered User
 
yaacovk is offline
Join Date: Jan 2008
Posts: 22
Flash firing without advance next frame

Recently I bought a flash with synch cable for my LEICA M4.
After I made one shot with the flash, i evidently pressed again on the shutter release without advancing to the next frame.
I paid attention that the flash fired again.
Is it normal? or do I have a problem?
Thanks in advance.
Yaacov.
  Reply With Quote

Old 1 Week Ago   #2
madNbad
Registered User
 
madNbad's Avatar
 
madNbad is offline
Join Date: Mar 2014
Location: Portland, Oregon
Posts: 689
First make sure your flash is plugged in to the X sync and not the M. If the problem persist there is a short between the two syncs and the camera will need service.
  Reply With Quote

Old 1 Week Ago   #3
yaacovk
Registered User
 
yaacovk is offline
Join Date: Jan 2008
Posts: 22
Well, i made a test with another LEICA, but it was LEICA M2, the results was the same...
If you have another old leics (untill M4...) you can make the same test.
  Reply With Quote

Old 1 Week Ago   #4
drewbarb
picnic like it's 1999
 
drewbarb's Avatar
 
drewbarb is online now
Join Date: Jul 2006
Location: Louisville, KY
Posts: 1,447
Don't worry; this is normal with the Leica. Each time you press the shutter button the circuit that trips the flash is closed, so the flash will fire whether the film is advanced and shutter re-cocked or not. There's nothing wrong with your camera.
__________________
-drew
  Reply With Quote

Old 1 Week Ago   #5
madNbad
Registered User
 
madNbad's Avatar
 
madNbad is offline
Join Date: Mar 2014
Location: Portland, Oregon
Posts: 689
Quote:
Originally Posted by drewbarb View Post
Don't worry; this is normal with the Leica. Each time you press the shutter button the circuit that trips the flash is closed, so the flash will fire whether the film is advanced and shutter re-cocked or not. There's nothing wrong with your camera.
Thanks! Just tried it on my M4.
  Reply With Quote

Old 1 Week Ago   #6
yaacovk
Registered User
 
yaacovk is offline
Join Date: Jan 2008
Posts: 22
Thank you all.
Your comments reassured me.
Yaacov.
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 12:46.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.