Ricoh GR1 - Strange Problem
Old 01-03-2017   #1
MiniMoke
Registered User
 
MiniMoke is offline
Join Date: Nov 2012
Location: Luxembourg
Age: 54
Posts: 457
Ricoh GR1 - Strange Problem

My 'new' GR1 worked flawlessly for the first half dozen rolls but now after standing empty for 3 days it won't turn on!

New battery won't help!

Now what's strange, as soon as I remove and replace the battery, the GR1 comes to life and works normally. Lens extends, LCD turns on - all OK.

When I open the film door and close it (with and without film) and press the power button it turns on and works normally.

When I turn it off with the power button it reacts instantly, so the power button seems to work. But then it can't be turned on again with the button!

At first I thought it was a faulty power button contact, but as it turns off at the slightest press of said button it seems to be OK.

Anyone has any clue about that?

Read somewhere there's a backup (watch)battery somewhere I could try to remove and replace.... if true, where did they place it?

I know they are not particularly reliable, but quitting on me so soon is annoying....
__________________
Meet me at www.whyfilmcameras.com
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 07:13.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.