Go Back   Rangefinderforum.com > Cameras / Gear / Photography > Leicas and other Leica Mount Cameras > Voigtlander Bessa Leica Mount Cameras

Voigtlander Bessa Leica Mount Cameras Made in Japan by Cosina in partnership with Voigtlander, the many modern Voigtlander Leica Screw Mount and Leica M mount bodies offer inexpensive and often unique options into entering the world of Leica rangefinder photography.

Reply
 
Thread Tools Search this Thread Display Modes

Help! R3A jammed
Old 01-23-2009   #1
PollitowuzHere
street shooter
 
PollitowuzHere's Avatar
 
PollitowuzHere is offline
Join Date: Jun 2008
Location: Puerto Rico
Posts: 68
Angry Help! R3A jammed

The shutter seems to be be jammed! I know I was running on short batteries, so I changed them but the camera still doesn't advance film nor fire the shutter. I opened the back cover to see that the second curtain is where it should be after winding, but the camera still doesn't react. Any help?
  Reply With Quote

Old 01-23-2009   #2
craygc
Registered User
 
craygc is offline
Join Date: Sep 2003
Location: Melbourne, Victoria
Age: 59
Posts: 1,073
I had my R2A shutter jam last year. Tried everything but eventually had to take it to a local repair guy to get fixed
__________________
Craig Cooper
Australia
Photo Stream
  Reply With Quote

You Tube
Old 01-23-2009   #3
Jodorowsky
Registered User
 
Jodorowsky's Avatar
 
Jodorowsky is offline
Join Date: Apr 2008
Posts: 201
You Tube

There's a piece on Youtube regarding the R3a shutter problems. Might help.

http://uk.youtube.com/watch?v=50AfjZcqA4k
  Reply With Quote

Old 01-23-2009   #4
PollitowuzHere
street shooter
 
PollitowuzHere's Avatar
 
PollitowuzHere is offline
Join Date: Jun 2008
Location: Puerto Rico
Posts: 68
It would be an incredible bummer to have to have the camera sent for repair, really nothing I could think of that might have damage a camera happened, tried to take a shot in A mode and the camera just froze there.
  Reply With Quote

Old 01-23-2009   #5
PollitowuzHere
street shooter
 
PollitowuzHere's Avatar
 
PollitowuzHere is offline
Join Date: Jun 2008
Location: Puerto Rico
Posts: 68
Odd, reseated the batteries and pressed down on the shutter button for a few seconds and the shutter and meter work again.
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 02:18.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.