Go Back   Rangefinderforum.com > Cameras / Gear / Photography > Classic Film RangeFinders & Other Classics > Yashica RF

Yashica RF For all Yashica Rangefinder cameras, whether fixed lens or classic Leica Screw Mount !

Reply
 
Thread Tools Search this Thread Display Modes

A question about Yashica M II
Old 09-08-2012   #1
fungun
Registered User
 
fungun is offline
Join Date: Sep 2012
Posts: 5
A question about Yashica M II

Hello everyone,

I am a new member of this forums. I have been shooting with digital SLRs for quite while, but have always been fascinated about rangefinders.

I have just acquired a Yashica M II in a very nice condition. This is my first range finder camera.

Here is this baby


I have got a question though, which I hope someone in here might know.

Although everything work, the LVS ring and the Coupling ring are very stiff. It requires quite a bit of effort to turn them. Is this normal? Anything I can do to improve the rotation?
__________________
http://www.tdj-studio.com
  Reply With Quote

Old 09-08-2012   #2
Peter_wrote:
Registered User
 
Peter_wrote: is offline
Join Date: Mar 2012
Posts: 462
the lvs ring of my minister II is quite stiff too. when i disassembled the lens to clean the shutter, i lubed the ring a bit inside. but i didn't really recognised a big change.

anyway congrats to your purchase. the yashica m II is a very nice looking camera. the lens is not razorsharp, but capable to produce some nice pictures. i especially like to use it with colour film. have a lot of fun!
  Reply With Quote

Old 09-09-2012   #3
fungun
Registered User
 
fungun is offline
Join Date: Sep 2012
Posts: 5
Thanks Peter.
I have just loaded it with a roll of fuji 200.
__________________
http://www.tdj-studio.com
  Reply With Quote

Old 12-16-2019   #4
Russell W. Barnes
Registered User
 
Russell W. Barnes is offline
Join Date: Aug 2018
Posts: 159
The rings on my Yashica Minister II were stiff so I dribbled a little isopropyl alcohol round the rings and into the gaps, and it seems a little easier now.
  Reply With Quote

Old 12-19-2019   #5
Smaug
Registered User
 
Smaug's Avatar
 
Smaug is offline
Join Date: Aug 2019
Location: Chicago
Posts: 284
I wonder if there's some old dried-up lube in there that needs to be cleaned out?
__________________
-Jeremy
*******************
My Flickr
My Cameras: Yashica Electro 35 GS and CC, Rollei 35, Nikon N90s, FG (2), FE2, and L35AF3, Minolta Freedom II, Olympus OM1N, OM10, Stylus (mju) and OM-D E-M10 III
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 03:01.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.