M9 Battery Issue
Old 10-17-2011   #1
Jimbot
Registered User
 
Jimbot is offline
Join Date: Feb 2011
Location: Newcastle Australia
Posts: 89
M9 Battery Issue

I am a sufferer of this M9 disorder:

http://en.leica-camera.com/news/news/1/8263.html

I haven't read too much about this particular issue here so I guess it must not yet be too widespread.
I have sent my camera to the Australian Leica- recommended service provider about a month ago. They have acknowledged the warranty issue and are waiting for the replacement part to arrive from Germany. ETA is 31 October 2011 at present.

I was just wondering how many members here have/are experiencing the "false battery low" issue and how long those who have had it fixed waited for the repair to be done?

Thanks
  Reply With Quote

Old 10-17-2011   #2
krötenblender
Registered User
 
krötenblender's Avatar
 
krötenblender is offline
Join Date: Nov 2010
Location: Germany
Posts: 801
I often have a similar problem, but I'm not sure, if this is the one mentioned in the link.

If one battery is empty, and I change to a fully loaded new one, after the first switch on of the camera, it shows an empty battery. If I switch the camera off an on again, the battery capacity is show correct most times. Sometimes I have to repeat that a few times.

But since I only have one Leica and three third party batteries, I am not sure, if the problem is in the camera or in the batteries. Two of my third party-batteries do not work at all in the M9, so I tend to think, that they are the problem.
  Reply With Quote

Old 10-17-2011   #3
250swb
-
 
250swb is offline
Join Date: Apr 2009
Location: The Peak District, United Kingdom
Posts: 859
Third party batteries are missing a circuit inside to allow the camera to tell the correct state of charge. They will show 'full' if fully discharged be fore charging, but an intermediate charge will often show 'battery low' even though full. Press the 'set' button to carry on shooting and when the camera realises its impossible that the battery is still working it recalibrates itself and shows the correct remaining charge.

But I think that problem is different to the OP's which is camera related.

Steve
  Reply With Quote

Old 06-03-2013   #4
raid
Dad Photographer
 
raid's Avatar
 
raid is offline
Join Date: Nov 2005
Location: Florida
Posts: 27,972
My M9 did not suffer from this issue before my trip to Italy during which tbere was lots of rain. I kept the camera dry, but now the camera just shuts off.
__________________
- Raid

________________
Top 12 Images;

http://www.rangefinderforum.com/rffg...n.php?cid=7007

http://raid.smugmug.com/
  Reply With Quote

Old 01-23-2014   #5
Clark.EE
Registered User
 
Clark.EE is offline
Join Date: Oct 2007
Location: Beautiful Hallaton, England
Posts: 296
My loan M9 suffered from this in 2012 during our South America Trip.
Very annoying. It didnt seem to occur all the time. & does not occur with the M8.
Surely you only need 3 connections on your battery to know what the charge state is. Nikon Olympus et al. can tell how much charge is in a 3rd party Battery!
Why cant a LeicaM9?
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 01:10.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.