Go Back   Rangefinderforum.com > Cameras / Gear / Photography > Fuji X Series > Fuji X-100 Series

Fuji X-100 Series This forum is for fans of the rangefinder retrostyled Fuji X Series of digital cameras.

Reply
 
Thread Tools Search this Thread Display Modes

Fujifilm UK and X10 repair - Praise!
Old 02-26-2014   #1
Mark Wood
Registered User
 
Mark Wood is offline
Join Date: Jul 2005
Location: Devon, UK
Posts: 426
Fujifilm UK and X10 repair - Praise!

Very nice to be in a position to praise Fuji's service.

My X10 (just over two years old) had developed problems with large dust spots on the sensor, often rendering it pretty much unusable at apertures smaller than f5.6 when large patches of sky were included in the frame. I contacted them their service centre in Bedford, telling them the problem and booked it in for repair on-line last Friday and then posted it to them on Saturday. So where are we four days later?

The camera is back with me, it has a brand new sensor (I didn't have it changed when they were doing that a while ago), the latest firmware and a long list of things they've checked/adjusted. They even e-mailed me yesterday to tell me it was on its way back.

A quick check suggests it's working properly again, so the total cost for this impressive service - 0. This is despite the fact that the camera is well out of warranty. OK, the postage to get it to them cost 8.25 but who's complaining?

Many thanks Fuji.
  Reply With Quote

Old 02-26-2014   #2
tbhv55
Registered User
 
tbhv55 is offline
Join Date: Nov 2009
Location: Devon, UK
Age: 61
Posts: 483
Thumbs up

Quote:
Originally Posted by Mark Wood View Post
Very nice to be in a position to praise Fuji's service.

My X10 (just over two years old) had developed problems with large dust spots on the sensor, often rendering it pretty much unusable at apertures smaller than f5.6 when large patches of sky were included in the frame. I contacted them their service centre in Bedford, telling them the problem and booked it in for repair on-line last Friday and then posted it to them on Saturday. So where are we four days later?

The camera is back with me, it has a brand new sensor (I didn't have it changed when they were doing that a while ago), the latest firmware and a long list of things they've checked/adjusted. They even e-mailed me yesterday to tell me it was on its way back.

A quick check suggests it's working properly again, so the total cost for this impressive service - 0. This is despite the fact that the camera is well out of warranty. OK, the postage to get it to them cost 8.25 but who's complaining?

Many thanks Fuji.
Yes, I have also had good service from Fuji. My first x100 developed SAB within a few months, and so the lens was replaced (camera was still under warranty). This was followed by a strange focus problem, and they then swapped the camera for a brand new one. The replacement camera was fine for about two years, but then developed SAB (this camera was now out of warranty). Fuji then fixed this with a replacement lens.

All this at no charge - not even for carriage - and all carried out very rapidly.

Although, at the time, it was frustrating and inconvenient to have these problems, Fuji were quick to put matters right, without a fuss. Definitely kudos to Fuji, from me.
  Reply With Quote

Old 07-14-2016   #3
Paul T.
Registered User
 
Paul T.'s Avatar
 
Paul T. is offline
Join Date: Mar 2005
Posts: 1,872
I've owned my X100 for four years. Got totally immersed once, and I've not particularly looked after it. It, especially, got very dusty and over the years the shutter button became sticky, the exposure compensation dial failed, then it started having intermittent focus problems.

Sent it in, knowing I'd probably have to pay. 75. For my 75 I essentially got a new camera - new top plate, new lens, the only bit that looks like my old camera is a slightly scuffed bottom plate. Turnaround was four days, and they're lovely people to deal with. Props to them.
Attached Images
File Type: jpg Fuji.jpg (18.6 KB, 9 views)
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 06:52.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.