PDA

View Full Version : 35RD Questions


Dough-Planet
01-12-2009, 05:54
Hello folks.
Last night I was snooping around in the cupboards in my family home (which have long been used to store all the redundant stuff that families tend to accumulate) and I was overjoyed to discover an Olympus 35RD. I naturally started playing with it (as you do) and after the 5th or 6th shutter action, it apparently jammed. The shutter button is in the half-pressed position and the wind-on lever (surely there's a term for that) doesn't go passed about 45 degrees from its default position. A bit of internet research has lead me to the assumption that it's the typical 35RD shutter jamming problem.
I would greatly appreciate any information anyone could give me on possible remedies for the problem, and an approximation of what it might cost to fix; Specifically in the UK.
Thanks for your time.

John Hermanson
01-12-2009, 06:09
Shutter will need a complete disassembly and degreasing. There is oil on the blades (which with age migrated out of the focus helicoid grease). Blades must be bone dry to work properly. There is no easy fix and you should be determined to get it done properly the first time. Luton Camera may be one place to check. John, www.zuiko.com

Dough-Planet
01-12-2009, 06:37
Thanks a lot for the speedy reply. I've sent a request for an estimate for the repair cost. I really wanna shoot with the thing, it's bloody gorgeous...Hope it won't be too far outside my student budget!

John Hermanson
01-13-2009, 06:15
Most likely, repair shop will have to see the camera to give you an estimate. John, www.zuiko.com