PDA

View Full Version : XA2 Back from the Dead


ncd_photo
04-11-2008, 14:22
My XA2 started playing up a couple of months back with a very erratic shutter - basically staying open too long and over exposing the shots.

I changed the batteries and it made no difference so I spent a few weeks searching the net for answers and came up with nothing. I resigned myself to the fact that the shutter had gone and put it on the shelf.

Well yesterday I found myself with some spare time so decided to open the camera up and have a look. Knowing the shutter was electronic I wasn't that hopeful but when I removed the base I found some spring contacts next to a couple of small electromagnets. Using a clean cloth impregnated with some electrical contact cleaner I gently rubbed away the oxidation on the contacts.

Hey Presto the camera has sprung back to life and the shutter is working fine. The release is better too so I guess its been on its way out for some time.

So I thought I'd share this with fellow XA owners in case you come across this problem in the future.

Time to fix - approx 45 mins!

ChrisPlatt
04-11-2008, 17:24
That's good news. The XA2 is a great carry everywhere camera.

Chris

AzzA
04-12-2008, 00:14
hehe nice work.
Its always very rewarding bringing something back to life :)

doitashimash1te
04-12-2008, 00:22
I have a dead XA as well. Last summer the shutter stopped working mid-roll. Your post inspires me to open it up and see if I can fix it myself. Thanks!

Mr XA
04-26-2008, 05:47
Nice work on the XA2 fix, and heres hoping you too get your XA working again!

TheHub
04-26-2008, 07:14
Thanks for the info.
I've been afraid to open the XA (or XA2 for that matter) since they're so complex inside.

Kapa
04-29-2008, 23:43
Good work. I had an XA with an eratic shutter and just sold it. My XA2 I've had about 5 years (and has traveled the world) just keeps on trucking. It's captured some mighty fine shots too if I might say so.... ;-)