PDA

View Full Version : Yashica GS shutter stuck at B if yellow is on?


terence
02-21-2005, 22:59
Hello,

I'm new to this forum but have been following it for a few weeks. It's a wealth of information and I've really got the bug now!

Anyway, I manage to buy 3 yashicas (GSN, GTN and a GS, don't ask why!) They feel really nice and I put a film thru th GTN and was amazed by the quality of the pictures (my main camera is a contax G2 with 28/45/90, well just bought a 2nd hand G1 and a new 21mm!!!)

THere seems to be some problems with the shutter of the GS though: when I sen it on AUTO, if the yellow light comes on, the shutter is stuck at B, i.e. the shutter only closes when I take my finger off the shutter release. Any idea if this is fixable?

Thanks in advance!

terence
02-22-2005, 06:38
I tried it indoors with a mix of natural and artificial light. The battery comes from my GTN which is 6v but of the right size. In any case, it's definitely on B as the shutter would not close unless I let go of the shutter release. This is not the case for my other Electros (a GTN which works fine: I put a roll thru it and it came out very nicely) which will open and shut the shutter regardless of whether I hold the shutter release or not.

I've done a bit more digging on the web and it's likely that it's the PAD OF DEATH! For a start there's not clunk sound when I cock the shutter (which the other 2 Electros do). I think I'll try to open it up and do the DEATH repair! Do you think I can use lightseals for this (bought them on the web from Jon Goodman)?

Wish me luck!