PDA

View Full Version : Olympus 35SP/SPN Repair Manual Needed


steve16823
01-03-2005, 12:20
Greetings everyone, My first post.

I purchased a Olympus 35SPN on E-bay a couple of weeks ago. However, it had a few functional problems -- one of them being stuck aperature blades.

I tried to get at them from the front yesterday, but got down to the shutter mechanism and it wasn't obvious how to remove the mechanism. I'm thinking now I have to remove the lens assembly from the body and start from the back.

I got the shutter back together and functional, but now I have no "B" shutter setting, so I'm guessing I must have the registration on the shutter ring off somehow.

Does anyone have a repair manual they could share with me?

Thanks,

Steve

g0tr00t
01-03-2005, 12:29
No manual, but this may help
http://www.kyphoto.com/classics/forum/

LionFlyer
01-21-2005, 10:13
When you put the plate that controls the shutter speeds back on you need to be sure that both parts with the protruding pins are in their slots. The pins on the left side are easy to miss. Here is a photo of my Oly SP which shows the pins in their respective slots. Hope this helps.

Doug
01-21-2005, 13:05
Welcome to RFF, Steve, and greetings to you too! LionFlyer, good to see you here again; I was just thinking the other day we hadn't heard from you for a while!

steve16823
01-21-2005, 19:01
Thanks for the replies guys, and LionFlyer, thanks so much for the photo -- I think it's exactly what I needed. I got the lens assembly off the body and was able to get the aperture moving again with a little dab of lighter fluid. I'll have to check the shutter ring to make sure the pins on the left are in the correct position.

Then, all I need to do is put the thing back together and replace the body foam.

I'll let you know how I make out. My first venture in home camera repair has been fun and certainly educational. If it turns out the camera actually works when I'm all done, it'll be icing on the cake ;)

g0tr00t
01-22-2005, 03:01
steve16823 - Keep us posted! That's fantastic!

steve16823
01-22-2005, 19:00
Well, I got the SPN all back together this afternoon. I did check the shutter ring, and all the pins appeared to be in the appropriate places.

The "B" setting still doesn't work. The shutter opens for about 1/2 second in this setting. While it's frustrating because it worked before I took it apart, it's not a huge deal at this point. I must have something not quite assembled correctly.

The battery check also quit working. I'm guessing I just have a wire or something blocking the switch. I want to see if the camera actually works before I get to excited about opening it back up to troubleshoot these minor problems.

So, I loaded it with some film and proceeded to take a few photos around the house tonight. Unfortunately, I discovered the flash synch doesn't appear to be working, either. As I turn the aperture ring past the "A" to the GN settings, the flash fires! But it won't fire when I trip the shutter. Again, this probably isn't a big deal for me -- I'm mostly thinking i'll use the SPN with available light anyhow.

I'm curious to finish shooting this roll of film to find out if the lens/rangefinder have accurate focus or if I messed up the infinity focus when I had it all apart.

Thanks again, and I'll post again when I know more.

-Steve