PDA

View Full Version : Retina II Type 011 Question


AlTheKiller
07-17-2016, 09:53
I got this Retina for free the other day and it seems to be in pretty good shape. The only issue I have run into (if it is an issue) is that the shutter release button wont depress. Is there a lock I am not seeing? I have never used one of these before so I have no idea if this is normal.

Heres a video of what I am talking about:

https://www.youtube.com/watch?v=L6T6gBgd5sg

madNbad
07-17-2016, 09:56
Reset the frame counter. Use the slider on the back to bring the frame counter to 36. Also the little button next to the frame counter will release the advance mechanism. Just looked at the video again and see you don't have the release button so resetting the frame counter should do it.

AlTheKiller
07-17-2016, 10:15
So it looks like my frame counter has an issue. I can sort of reset it but for only a single photo. When advancing the film, it feels like a cog/wheel is skipping on the inside.

Video: https://www.youtube.com/watch?v=pZqwufCogLI

madNbad
07-17-2016, 11:35
Check out Chris Sherlocks' website dedicated to Retina. He mentions a common problem could be a broken spring for the frame counter.

Swift1
07-17-2016, 12:36
The Retina II Type 011 was designed with a double exposure prevention that kinda requires film to be loaded.
If you are testing it without film, you need to,

1- Open back
2- Turn wind knob
3- Manually advance sprocketed roller until it stops
4- cock the shutter

It should allow the shutter button to trigger the shutter now.

Hope that is helpful,

Edit: Just watched your video. It actually looks like it's working properly. IIRC the Retina II frame counter counts upwards from 0, whereas the Retina III counter counts downwards from 36. If you set the counter to 0 it should wind smoother.