PDA

View Full Version : Olympus OM-2n shutter issue


NirB
11-09-2015, 07:54
Hi, this is my first post here.
Have OM-2n which was functioning and I also shoot few rolls.
Lately while playing with it I noted that the shutter button was stuck, tried to open it and it seemed that the delay action level is touching the shutter rod and stopping it from going freely. The film advance lever was stuck too.
After reading the very detailed OM-1 service manual, I removed the bottom cover and removed sprocket (no.1 in my pic), I read somewhere that it was not in the right position. When I returned it in the right position, the film could be advanced and the shutter could be pushed freely again but pushing the shutter does not make the “click”.
To “take” picture I have to manually push 2 levers (no.2 and then no.3) and only then it shoots and I can advance again.
When pushing the shutter release button, the bar moves to right side of the picture (red arrow) but it was supposed to push a small pin (no.4) which I cannot see now (I took that picture before dissemble).
So what I think is this pin is hidden somewhere below and I cannot even get a look of it.

Please guide me if you also think this is the problem and if so how can I get to it - do I need to take it further apart (which I prefer not unless have to)?

Thanks,
Nir.

maxmadco
11-09-2015, 08:45
I would not have tried to fix something like that myself and you may be in way over your head.

Trius
11-10-2015, 16:37
Are the batteries good?

NirB
11-13-2015, 12:48
Yes I tried new batteries.
The problem is mechanical since in the past I manged to advance and shoot even without batteries (it serves only the light meter as I know).
I would prefer to fix it myself (not going to use it, just like to have is in working condition).
I saw one sold in ebay for $40 so it also does not worth giving it to specialist.

xayraa33
11-13-2015, 14:14
Years ago my shutter release button stuck on my OM 1 after having a shutter release cable screwed in and removing it after using the camera on a tripod.

I found that placing a very thin slot type screwdriver in the hole where you normally screw in the shutter release cable and turning it a few turns clockwise released the stuck shutter release button on the camera.

farlymac
11-15-2015, 18:43
I can see where it looks like someone has been in there before, as the big screw head is marked up from a slipping screwdriver.

There is always the possibility a spring has come off its retaining post, or even broken. Check if any lever seems to be loose, just swinging back and forth with no resistance.

Work the mirror up and down a couple of times with the external button on the side of the mirror box. And that screwdriver trick sounds like it might do some good. Sticky lubricant can play havoc with camera internals, especially if it migrates to somewhere it's never been before.

PF

ps: Don't be surprised if a Moderator moves this to either SLR's, or Camera Repair. They'll leave a link behind here if there do, so you can still find it from this forum section. And welcome to RFF!

NirB
11-17-2015, 08:19
will do.
Thanks.

xayraa33
11-17-2015, 08:25
Also check to see if the mirror cocking arm has becomes unlatched. That leaves shutter cocked but the mirror will be un-cocked. The mirror flipping up is what ultimately fires the shutter.