PDA

View Full Version : XA2 Shutter won't fire


st. paulitan
12-27-2014, 07:05
Just bought an XA2. The shutter worked for a couple shots, then stopped. I disassembled and cleaned the contacts under the shutter button, then reassembled. The self timer works when I press the red button (beeps), but the shutter won't fire. Since the self timer activates when the button is pushed, I'm assuming those contacts are good. Any other thoughts? I do have an XA2 junker I'm using for practice, parts, etc.

Thanks!

Bill

wblynch
01-06-2015, 14:41
Make sure the sliding door is fully open. Try holding it. There is a lever switch that locks the shutter unless the door is open all the way.

FrankS
01-06-2015, 15:37
Hi Bill, I have an xa2 that's developed a reluctant shutter button. Can I ask how you accessed the contacts below the red button?

Solinar
01-06-2015, 15:45
Modern technology at your finger tips, as shown in the thread below.

http://www.rangefinderforum.com/forums/showthread.php?t=137072

Best Regards,

FrankS
01-06-2015, 16:37
Thank you.

Petrolhead
01-06-2015, 21:50
Just bought an XA2. The shutter worked for a couple shots, then stopped. I disassembled and cleaned the contacts under the shutter button, then reassembled. The self timer works when I press the red button (beeps), but the shutter won't fire. Since the self timer activates when the button is pushed, I'm assuming those contacts are good. Any other thoughts? I do have an XA2 junker I'm using for practice, parts, etc.

Thanks!

Bill

If there are no contaminants on the shutter blades, very likely the electronic solenoid and the linkages are dirty.

Here's a test you can do to determine if the solenoid is stuck or the shutter linkages are dirty. If I hear you correctly, the shutter release button has been cleaned and is responding. Shutter also does not fire at the end of the countdown on self timer mode.

Switch the lever at the bottom to battery check, red led should light up and beeper should sound, press the shutter button, if camera is working correctly shutter should fire, if the solenoid is stuck or the shutter linkages are dirty, the led intensity should dim indicating that the solenoid is drawing high current and movement is limited by dirt on the solenoid or on the linkages which will warrant a CLA.

These findings are based on the Oly XA but I believe the XA2 is not much different.

julio1fer
01-10-2015, 13:21
Open fully the sliding door and press down on the lower part of the door near the lens. Then try the shutter to see if it works reliably while you are pressing. If so, the culprit is the door-open sensor microswitch.

There is a microswitch below that door that gets reluctant with time (it happened to my XA). For the shutter to release in the XA, you need several microswitches to be in the right way, not only the shutter button.

st. paulitan
01-12-2015, 07:20
Thanks, guys! Tried the tests suggested and nothing worked. Tried the shutter with the battery check on and the light didn't dim. Pressed the bottom of the door and that didn't work either. May be time to track another XA2 down............

Bill