PDA

View Full Version : XAs flash problem


adresaba
09-01-2014, 10:56
Hello
few months ago I bought nice XA and flash A11 as a gift. Camera is great and I really like it but flash wont fire. I put a fresh battery in it and I hear a charging sound but charging light never lights and when I press the shutter flash dont fire. Guy who gave me this told me that it was unused for a long time so I left it charging for 7-8 hours and always the same, I hear the buzzing sound but flash wont fire.
It would be nice to have a working flash so if anyone had a same problem or have an idea what to do please help.

p.s. I borrow A11 flash from a friend and it works

Sorry for my bad English, I am not using it often last few years so I am worse then before :)

NeeZee
09-01-2014, 11:28
I own an XA with an A16 flash and it works flawlessly but I encountered the same problem you have with quite a few old integrated flash cameras as well as older external flash units. I'm no camera tech but my guess is that you would be better off looking for a working unit. You don't see them offered without a camera very often but you might find one offered together with an XA2 for a low price. You'd also get a nice scale focusing camera as a bonus then ;)

Landshark
09-02-2014, 19:36
It's pretty likely to be the main capacitor. The ready light comes on when this is fully charged.
It sounds like you've already tried to reform it. The only real fix would be to replace the capacitor. It's not hard but even a partially charged cap can give you a shock.
Do you know anyone that repairs electronics?

Chris101
09-02-2014, 20:23
A flash not firing could be just about anything.

Gently shake the unit and listen closely. A thunking could mean the coil has overheated and cracked. The sound of broken glass means the tube broke, probably when it was dropped. Rattling means something inside is loose, possibly shorting it out.

You say it makes the power-up whine. Does the pitch increase to quite a high value, then level off and become quiet? If so the capacitor is most likely ok. If the squeal stays the same pitch, or does not fade, then the cap is not charging.

In the long view though, I agree with NeeZee. Buying an A11 that you know works would be cheaper and shorter than diagnosing and repairing the one you have.

btgc
09-02-2014, 21:18
When I bought my XA2 seller posted also picture with glowing charge light of flash, stating it's working opposite to many not working. This were only time I've read about failing XA-series flash units, until I read this post.

adresaba
09-03-2014, 10:59
I could hand it over to repairer but if its something easy to fix I would like that better. Thanks guys, and Chris101 I will try what you suggest, check the sound

adresaba
11-09-2014, 11:11
At the end I bought one from e bay :)