View Full Version : She's dead Jim. (R3M meter no longer lights up)

travis forsyth
04-18-2011, 19:21
I recently got my CV Bessa R3M and it's been working wonders up until this afternoon while shooting the LED readout for the light meter quit working on me. I thought "Okay, probably the batteries I'll just meter with the iphone until I can slap some fresh ones in it" and that worked all fine and dandy to finish off the day. Now that I got home with a fresh set for it I swapped out the batteries and there is still no red blinky numbers for me to see.

What may be the problem? Is it possibly something I could fix with a steady hand since it was purchased used from Leica Boutique I don't know if there is any warranty on it.

Any sort of feedback would be greatly appreciated. I love this rangefinder to death (maybe too much love killed it :P ) and I am just not so content with shooting with only my iphone to meter.


Edit Super Mega Awesome Update: Problem solved, I'm a slow individual. It helps if I put the fresh batteries in the camera... and not just the old ones over and over.

Gary E
04-18-2011, 22:32
This is a super example of why I might have enjoyed the R3M instead of the R3a. As much as I like to have a built in meter as well as being able to shoot in AE mode, mechanical cameras just give you that extra life support you need when out on a shoot and the batteries die; plus you forgot to carry spares. This is also why I regret not buying that Nikon FM3a way back :bang:

04-19-2011, 07:40
Once I put the batteries in wrong way????? But that was a BessaR.

travis forsyth
04-19-2011, 11:21
Once I put the batteries in wrong way????? But that was a BessaR.

At least you put the right set of batteries into it :D Not sure what I was doing putting the same set I pulled out back in over and over.

Red Robin
06-04-2011, 04:59
Once I put the batteries in wrong way????? But that was a BessaR.
Yup! Had been wondering why my Bessa R had no meter. Replaced the old batteries, Nada, kaput! Checked an old manual, , rechecked the type, gave up. Then then this morning i saw this thread! All is right with the world -for now. My meter lives again!

09-07-2011, 11:19
I just got the same issue with my R2M :(

Swapped batts, still nothing.

09-07-2011, 21:38
Seems she's just picky.

I offered her another batch of batteries, and now she seems all fine and dandy again!

Leigh Youdale
09-07-2011, 23:05
I'd suggest always use SR44 batteries, not LR44, and check the contacts are clean too.
As for the original post - might be a repair job. If it's electronic (and the "A" models have a circuit board - I think it's under the top cover) you'd be unwise to mess with it. Just get a new board fitted.