Go Back   Rangefinderforum.com > Cameras / Gear / Photography > Classic Film RangeFinders & Other Classics > Argus RF

Argus RF Forum for Argus RF nuts. The American made Argus C-3 may be the most prolific rangefinder, with over 3 million cameras produced! While American RF nutz of the 1950's may have yearned for a Leica, Zeiss, Canon or Nikon, most of them used an Argus !

Reply
 
Thread Tools Search this Thread Display Modes

Argus C44 shutter problem.
Old 10-14-2012   #1
timor
Registered User
 
timor is offline
Join Date: Aug 2010
Posts: 363
Argus C44 shutter problem.

Hi. Just got very nice looking C44, almost unused and after a few clicks the shutter got stuck in an open position. Please help.
  Reply With Quote

Old 10-15-2012   #2
J.Ed
Registered User
 
J.Ed's Avatar
 
J.Ed is offline
Join Date: Sep 2003
Location: North Chili, N.Y.
Age: 63
Posts: 79
It may be too late. There are three possible problems that could cause the shutter to stick open. Two are repairable, one fatal. Do Not continue to try to fire the shutter!! Refer to Rick Olsen's site ( http://rick_oleson.tripod.com/index-128.html ) for diagrams for disassembly. The first problem is that there is oil on the shutter blades that needs to be cleaned off, this can (and will) cause the fatal problem of breaking the link that drives the shutter. Another possible problem is that the mainspring has either broken or become unattached where it connects to the camshaft. There are several very good technical people at the Argus Collectors Group ( http://www.arguscg.org/ ) if you need more help.
__________________
<a href='http://www.rangefinderforum.com/photopost/showgallery.php?cat=500&ppuser=108'>My Gallery</a>
  Reply With Quote

Old 10-16-2012   #3
timor
Registered User
 
timor is offline
Join Date: Aug 2010
Posts: 363
Thank you for the respond. I found Oleson page and it is very helpful with the drawings. Right now I am half way with disassembly. It was kind of painful to cut trough perfectly good and original leatherette to get to the screws. Well.
I was just hoping someone here did such a repair and have first hand experience to share. I gonna go with your pointer and sign up with www.argus.org for more info how actually fix that problem. If successful I will report back.
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 14:56.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.