Go Back   Rangefinderforum.com > Cameras / Gear / Photography > Leicas and other Leica Mount Cameras > Leica M -- Leica CL / Minolta CLE

Leica M -- Leica CL / Minolta CLE This forum is about all things Leica CL and Minolta CLE, remarkable compact M cameras

Reply
 
Thread Tools Search this Thread Display Modes

Minolta cle repair manual
Old 04-14-2015   #1
jacquestati
Registered User
 
jacquestati is offline
Join Date: Mar 2015
Posts: 2
Minolta cle repair manual

As the battery control on my CLE is out of order - is there anybody outside owning a pdf of the repair manual?
  Reply With Quote

Old 04-14-2015   #2
Palaeoboy
Joel Matherson
 
Palaeoboy is offline
Join Date: Oct 2005
Location: Australia
Posts: 626
The CLE manual is bound by copyright so I have only a hard copy of the original manual. I have never seen a pdf version.

When you say the battery control are you referring to the on/off/timer switch? In what way is it our of order?
  Reply With Quote

Old 04-15-2015   #3
jacquestati
Registered User
 
jacquestati is offline
Join Date: Mar 2015
Posts: 2
Dear Joel, the led in front of the camera does not work when checking the battery and after releasing the self timer. So I presume the led is defective as the AE and the shutter are ok. Should be a Lumex led (SSl-lX 203CIT type) and I could replace it myself, but I am not quite shure. Regards, Thomas
  Reply With Quote

Old 04-16-2015   #4
Palaeoboy
Joel Matherson
 
Palaeoboy is offline
Join Date: Oct 2005
Location: Australia
Posts: 626
Quote:
Originally Posted by jacquestati View Post
Dear Joel, the led in front of the camera does not work when checking the battery and after releasing the self timer. So I presume the led is defective as the AE and the shutter are ok. Should be a Lumex led (SSl-lX 203CIT type) and I could replace it myself, but I am not quite shure. Regards, Thomas
I have yet to see an actual blown LED on a CLE. I have seen on several occasions where a technician unfamiliar with this particular camera who has removed the baseplate and severed the connection from the battery compartment upon removal of the baseplate and misses a reconnection wire that goes to the main switch and LED when they put it all back together again. I would look into this as to the cause rather than a blown LED.
  Reply With Quote

LED Wire
Old 04-24-2015   #5
Shafovaloff1
Registered User
 
Shafovaloff1 is offline
Join Date: Aug 2014
Posts: 45
LED Wire

I have some CLE photos posted on Ebay with one showing the base circuit board. Which wire are we talking about. My method when removing the base plate is to tape it to the side so there is no undue tension that could result in having the need for resoldering. Hope this helps. Tom S.

Last edited by Shafovaloff1 : 04-24-2015 at 18:53. Reason: Spelling
  Reply With Quote

One More Thing
Old 04-24-2015   #6
Shafovaloff1
Registered User
 
Shafovaloff1 is offline
Join Date: Aug 2014
Posts: 45
One More Thing

Had trouble with LED read out in finder. Probably some oxidation on contacts, AE still worked fine so was not going to repair. Then put generic flash on - which of course sends real current through this finely made camera circuitry. To my surprise, the LED's began working immediately after setting off the flash. Think may have altered the errant connection resistance - overcame it - now LED's work fine. Might be a quick fix for a CLE needing contact cleaning on the near term. May be the flash contacts themselves under the top that were problematic! Cheers!
  Reply With Quote

Old 11-28-2016   #7
animaux
Registered User
 
animaux's Avatar
 
animaux is offline
Join Date: May 2015
Location: Weimar, Germany
Age: 37
Posts: 7
Wanted to share this with anyone looking for CLE-repair:

A nice japanese guy told me about the likely last CLE-repairman. Prices seem reasonable. You would have to send the CLE to Japan though.

https://translate.google.com/transla...-text=&act=url
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 20:29.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.