Go Back   Rangefinderforum.com > Cameras / Gear / Photography > Gearhead Delights > Repair / Camera Care

Repair / Camera Care This is a good place to discuss the care and repair of your photo gear. You can share Do-It-Yourself repair and maintenance, as well as your recommendations for pro repairs. This new forum was created 4/1/07. PLEASE title your thread wisely, so others searching for a certain make of camera or repair person can find your thread easily!

Reply
 
Thread Tools Search this Thread Display Modes

Olympux XA Shutter Question
Old 07-08-2014   #1
n17man
Registered User
 
n17man is offline
Join Date: Jul 2014
Posts: 4
Question Olympux XA Shutter Question

I have acquired an Olympus XA in very good overall condition. Battery check works. Shutter works intermittently. I have dismantled the shutter button mechanism and discovered that one piece, the button release rubber flange (grey) was in fact floating loose in the shutter well.

I also discovered that the button spring seems to be completely flat, with no visible capacity for 'springiness', in the language of the XA repair manual, 'deformed'. See photo of the parts below.

Since the camera does work and is in good condition I have two questions:
  • what would be the impact of the missing 'floating' rubber release flange?
  • what is the best way to restore 'resilience' to the button spring?

Just by way of a stray thought: is the XA shutter button assembly a version of an early momentary electronics switch? If so ..... then .... !

  Reply With Quote

Old 07-09-2014   #2
farlymac
PF McFarland
 
farlymac's Avatar
 
farlymac is offline
Join Date: Jan 2009
Location: Roanoke, VA
Posts: 5,108
You re-tension the spring by bending the tabs back into shape. Look for an image to see how much bending is needed, or just give it a good guess.

PF
  Reply With Quote

Old 07-12-2014   #3
n17man
Registered User
 
n17man is offline
Join Date: Jul 2014
Posts: 4
Thank you. I will try that. Work in progress.
  Reply With Quote

Old 12-30-2016   #4
One Star Over
Registered User
 
One Star Over is offline
Join Date: Sep 2016
Posts: 1
Any luck?? I have an XA here that I loved to use but the more I used it the more intermittent the firing of the shutter became. Now it doesn't work at all. The "spring" inside was flat when I removed it. I don't know which direction to bend the spring in an effort to re-tention it. When it shutter components are separated it works. When the two metal pieces inside make contact the shutter fires (if that makes sense).
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 16:40.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.