Go Back   Rangefinderforum.com > Cameras / Gear / Photography > Classic Film RangeFinders & Other Classics > Olympus RF

Olympus RF This forum is for the Olympus rangefinders.

Reply
 
Thread Tools Search this Thread Display Modes

Olympus SP shutter speed adjustment noise
Old 07-11-2016   #1
YorkshireLuchador
Registered User
 
YorkshireLuchador is offline
Join Date: Jul 2016
Posts: 2
Olympus SP shutter speed adjustment noise

Hi all, new to the forum and have my first question. I have been after an SP for some time now and took a punt on one on ebay. It seems to be in great condition, lens and viewfinder are very clear. I have yet to test the meter as my new battery is at home, so fingers crossed for that, that is what I am most nervous about! First thing I noticed is when I turn the shutter speed dial on the lens, it makes a little sound that is like the self timer. Is this normal?

Any help or tips of what else to check for would be very much appreciated.

I look forward to becoming more active on this forum now I finally have a rangefinder
  Reply With Quote

Old 07-11-2016   #2
02Pilot
Malcontent
 
02Pilot is offline
Join Date: Jan 2011
Location: NY, USA
Posts: 1,030
Mine did that too. I think it's just a function of the Seiko shutter's design. I found the shutter one of the least appealing parts of the camera - nothing wrong with it functionally, mind you, but just not particularly smooth.
__________________
-------------------------------------------------------
Any man who can see what he wants to get on film will usually find some way to get it;
and a man who thinks his equipment is going to see for him is not going to get much of anything.

-Hunter S. Thompson
-
http://filmosaur.wordpress.com/
  Reply With Quote

Old 07-12-2016   #3
YorkshireLuchador
Registered User
 
YorkshireLuchador is offline
Join Date: Jul 2016
Posts: 2
Hey thanks a lot O2Pilot, I managed to find another post on another forum, seems it is totally normal. I replaced the battery last night and cleaned the camera up a bit, seems to be working beautifully, the light meter seems to be working, let's see how the first roll turns out!
  Reply With Quote

Old 07-12-2016   #4
Sarcophilus Harrisii
Brett Rogers
 
Sarcophilus Harrisii is offline
Join Date: Jun 2009
Location: Australia
Posts: 1,969
I'm not familiar with the specifics of that camera but it is worth noting that some designs will wind the escapement as the slower speeds are selected with enough vigour to produce a noise akin to the sound they make when they are running off. The Zeiss Icarex and certain older DDR cameras come to mind. It's simply the noise the mechanism produces as certain speed ranges are selected on the dial. As long as it is running well at all its speeds, personally I would not be concerned about it.
__________________

  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 16:26.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.