Go Back   Rangefinderforum.com > Cameras / Gear / Photography > Classic Film RangeFinders & Other Classics > Fixed Lens 35mm RF

Fixed Lens 35mm RF This forum is dedicated to the numerous and popular fixed lens rangefinders, including but not limited to the Canon Canonets, Konica III and S series, Minoltas, Ricohs, Vivitars, and so many others. Note fixed lens Olympus , Yashicas, Argus and Retina have separate forums.

Reply
 
Thread Tools Search this Thread Display Modes

Voigtlander VF101 problem
Old 09-01-2016   #1
Arbitrarium
Registered User
 
Arbitrarium's Avatar
 
Arbitrarium is offline
Join Date: Aug 2016
Posts: 141
Voigtlander VF101 problem

Hiya,

I've got my hands on a VF101 and it's probably the most gorgeous camera I've ever laid my eyes on.

So obviously it's broken.

I've fit a brand new CR123 battery and the light meter is fully functioning yet the shutter seems to always fire at 1/500 regardless of what the meter is reading.

Some details:

It's not in flash mode (flash mode also fires at 1/500). The battery polarity is correct. I've tried it with a film inserted. There's no battery corrosion.

The manual says flash mode fires at 1/30 so it's not somehow stuck on that. So I'm totally stumped. Any help would be mightily appreciated!
__________________
Arbitrarium on Instagram
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 17:48.


vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.