Go Back   Rangefinderforum.com > Cameras / Gear / Photography > Classic Film RangeFinders & Other Classics > Xpan & Other Panoramics

Xpan & Other Panoramics For Hasselblad Xpan, Xpan II, Fuji TX-1 and TX-2, and all other Panoramic cameras

Thread Tools Display Modes

Xpan DX sensor reader
Old 05-02-2012   #1
Registered User
finguanzo's Avatar
finguanzo is offline
Join Date: Aug 2009
Location: EWR
Posts: 725
Xpan DX sensor reader

Have any of you XPan 1 users ever noticed the DX reader giving you the wrong film iso..???
Just loaded a roll of tri-x, when i put it on DX, screen says iso100....
Not sure if the canister was printed wrong, or if something is starting to go in the camera, didnt have this on my last roll last week, same tri-x pack..
I guess Ill find out once I develop the roll, open up the back, was just curious..
  Reply With Quote

Old 05-02-2012   #2
It's friday!
zthee's Avatar
zthee is offline
Join Date: Jan 2012
Location: Stockholm, Sweden
Posts: 41
Check for dirt on the pins when you finished the roll?

I haven't had this problem.
  Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -8. The time now is 21:41.

vBulletin skin developed by: eXtremepixels
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.

All content on this site is Copyright Protected and owned by its respective owner. You may link to content on this site but you may not reproduce any of it in whole or part without written consent from its owner.