PDA

View Full Version : ruined slides


mervynyan
08-30-2007, 08:10
I had 2 rolls of Kodak E100VS developed yesterday, they came out disasterly. All of them are uniformly too dark and dark reddish. It seemed the slides were developed fine since the perforation look fine.

My guess is that the shutter runs at only one high speed, hence the uniformity of darkness. But I canít understand the dark reddish on the slides, I didnít use any filter or sort.

Any thoughts before I try few C-41 print films?

Dr. Strangelove
08-30-2007, 08:30
My guess is that the shutter runs at only one high speed, hence the uniformity of darkness. But I canít understand the dark reddish on the slides, I didnít use any filter or sort.

Any thoughts before I try few C-41 print films?
I don't know about the reddish cast, but if your shutter only runs at one high speed and you took the shots in variable light conditions, many of the frames should be very dark with no details visible. Slide film really can't take much underexposure before it gets completely dark. My guess is that the light meter of the camera is calibrated way off or even malfunctioning.

MartinP
08-30-2007, 08:44
I am curious to hear which camera this happened with - Mamiya or Leica ?? If the shutter is really single-speed then does it look that way with the back off/open ?!

mervynyan
08-30-2007, 10:06
it was a hasselblad with 80cf lens, i understand the idea of leaf shutter and adjust according to light meter reading, i am positive about readings were correct. I will try few more c-41 print films and see what will come out.

payasam
08-30-2007, 10:12
The likelihood is that the processing was faulty.